POICMD

POICMD 1.1 Beta2

This software is provided "as is" without warranty of any kind. The author disclaims all warranties, either express or implied, including the warranties of merchantability and fitness for a particular purpose. In no event shall the author be liable for any damages whatsoever including direct, indirect, incidental, consequential, loss of business profits or special damages.
Even though POICMD is freeware, it is not in the public domain, I reserve all rights to it. You may freely distribute copies of POICMD as long as you do so in an unmodified form and include all files and documentation that are present in the original archive. You may not charge for the distribution of POICMD other than a reasonable fee to cover your distribution costs.

The POICMD command line tool enables you to create, convert and dump so called "Point of Interest" files in various formats.

Author

Harald-René Flasch
mailto:hfr@hfrmobile.com
http://www.hfrmobile.com

Commands

  • dump
  • gs
  • ss
  • cx

Further help topics

  • Return values
  • Syntax & Terms
  • Parameters
  • Command parameter values

History

The following table contains all released versions of POICMD and a short description for each version:

Version Description
1.1 Beta2
  • Improved help
  • Added setup
  • Added support for .itn files (TomTom Navigator route files/itinerary files)
1.0
  • First release with commands dump, gs, ss and cx
  • This version does not have an installer, so just extract the files into a folder of your choice and use POICMD


Return values

After executing a command POICMD returns a value to its caller. This return value can be used in batch files (e.g. *.cmd or *.bat). You can use the %errorlevel% environment variable in order to retrieve the return value. For example if you call "poicmd" without parameters the return value will be 2.

Here is a complete list of all possible return values:

Value | Meaning
0 | POICMD successfully executed (and parameters where specified)
1 | There where parameters but nothing to do (e.g. poicmd /help)
2 | No parameter was specified. This is just a 'warning'.
4 | You have specified an unknown parameter.
5 - 9 | Not used.
10 | The specified file could not be found.
11 | The specified file already exists.
12 - 19 | Not used.
20 | You have specified an invalid number of command values.
21 | An command parameter value has an invalid value (e.g. /lat:4801xy)
22 - 98 | Not used.
99 | Unspecified error. Look at the error message which gives you some information about the problem.
100 - .. | Not used.


Syntax & Terms

This topic describes the general syntax of POICMD and some important words and symbols which are used in this documentation.

Note
  • All commands and their parameters are case sensitive
  • Do not repeat commands

Term | Description
POI file poifile | Point of Interest file (e.g. .ov2, .kml)
lat | lat stands for "Latitude"
lon | lon stands for "Longitude"
src | src stands for "source" (e.g. a source poifile)
dst | dst stands for "destination" (e.g. a destination poifile)
[ ] | Square brackets means that something is optional (e.g. dir [filespec] means that for the dir command the filespec is optional)
< > | These kind of brackets means that something is mandatory and needed for a successful execution (e.g. del <filespec> means that the filespec is mandatory for the del command)
| | This symbol means "or". (e.g. <alpha | beta> means that you have to use alpha or beta)


Parameter

Parameters

This topic describes the POICMD parameters. An parameter must go first. The general syntax is:
POICMD [parameter(s)] [<command> [command parameter(s)]]

Here is a list of all parameters:

Parameter | Description
/? | Displays general help for poicmd
/values? | Displays help for command and parameter values
/nologo | Suppresses displaying program information.
/errorlevel | Displays the "DOS" return value. See also return values.
/kmns:<ns> | Provides a namespace used for KML or KMZ files. Change the namespace at your own risk! This parameter was implemented in order to stay compatible with future version of Google Earth.


Command parameter values

This topic describes command parameter values (in alphabetic order).

<LAT>

Value | Description
XXXXXXX | Coordinate is stored as 4-byte integer representing a WGS84 Latitude multiplied by 100000 and rounded to the nearest integer. Should be a value between -9000000 and +9000000. Sample: 3895940

<LON>

Value | Description
XXXXXXX | Coordinate is stored as 4-byte integer representing a WGS84 longitude multiplied by 100000 and rounded to the nearest integer. Should always be a value between -18000000 and +18000000. Sample: -9526550

<method>

Value | Description
first | Used by gs command to get the first POI from a poifile.
single | Used by gs command to get exactly one poi from a poifile. If the poifile contains more than one pois the gs command may fail. Use first instead.

<name>

Value | Description
XXXXXXX | Name of a POI. Since poicmd supports various poifile formats I recommend to not use special characters like "':;\/<> etc. because some file formats may not work with such characters.

<type>

Value | Description
ov2 | TomTom Navigator overlay file.
itn | TomTom Navigator itinerary file. Also called "route file".
kml | Google earth KML placemark file.
kmz | Google earth KMZ placemark file. Note that this format is currently not directly supported by poicmd. In order to create KMZ files you can create KML files and use a ZIP program (e.g. WinZip, WinZip Command Line (wzzip.exe)) to zip the KML file to a KMZ file.

<sym>

Value | Description
Building | 3D Building (see also cx command)
GreenCar RedCar YellowCar | Car symbol (see also cx command)
Flag | Flag symbol (see also cx command)
Info | Info symbol (see also cx command)
Pin | Pin symbol (see also cx command)


POICMD dump

dump

The dump can be used to dump the entire POI file.

Syntax: dump <poifile> [parameter]

Paramter | Description
/t:<type> | Specifies the type of the poi file. If this parameter is not specified the type is determined by the file extension of poifile.


POICMD gs

gs

The gs (get single) command retrieves the first POI from a POI file.

Syntax: gs <poifile> [parameter]

Paramter | Description
/t:<type> | Specifies the type of the poi file. If this parameter is not specified the type is by the file extension of poifile.
/m:<method> Specifies the method used to retrieve a single POI from a POI file. Following methods are possible:
  • first: Retrieves the first POI from the file. The file may contain more than one POIs
  • single: The file should only contain one POI otherwise the method may not work. If using this method I recommend using it only for POI files created with the ss command


POICMD ss

ss

The ss (set single) command creates a POI file with one POI.

Syntax: ss <poifile> [parameter]

Paramter | Description
/lat:<LAT> | Latitude in WGS84 format.
/lon:<LON> | Longitude in WGS84 format.
/n:<name> | The name for the POI.
/t:<type> | Specifies the type of the poi file. If this parameter is not specified the type is determined by the file extension of poifile.
/o | Specifies if the file should be overwritten if it already exists. Default setting does not overwrite an existing poi file.


POICMD cx

cx

The cx (convert; x stands for various poifile formats) command can be used to convert POI files from one format to another.

Syntax: cx <src> <dst> [parameter]

Paramter | Description
/src:<type> | Type of the source poifile. If this parameter is not specified the type is determined by the file extension of src poifile.
/dst:<type> | Type of the destination poifile. If this parameter is not specified the type is determined by the file extension of dst poifile.
/o | Overwrites the destination poifile if it exists. If this parameter is not specified and the destination poifile exists the command will return with an error.
/sym:<sym> | At the moment this parameter can only be used if dst is kml. You may specify a complete url to an image file or use one of the following predefined special Google Earth symbols: Building Building, Green car GreenCar, Red car RedCar, Yellow car YellowCar, Flag Flag, Info Info, Pin Pin Pin is the default setting.


POICMD Author

Author

This is a "hidden" page about the author (me ;-)) of POI Command (POICMD). You may click on the image on the author page of my homepage... ;-)

Picture of the author

Name: | Harald-René Flasch
Contact: | hfr@hfrmobile.com
Homepage: | http://www.hfrmobile.com